Intermittent Service Degradation Affecting Multiple Products

Incident Report for Diligent Customer Facing

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 14:43 UTC

Identified

We are currently experiencing intermittent service degradation affecting multiple products. The issue originates from one of our third-party service providers. We will continue to share updates as we receive them. Thank you for your patience and understanding.
Posted Nov 18, 2025 - 13:24 UTC
This incident affected: Boards & Governance – iCompass (iCompass (North America - Canada)) and Tools - Academy (Academy (North America - US)).