BoardDocs - Users are experiencing latency and unable to access the application

Incident Report for Diligent Customer Facing

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 18:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2026 - 18:17 UTC

Identified

Customers are experiencing heavy latency when attempting to use the application.
Posted Jan 14, 2026 - 17:47 UTC
This incident affected: Boards & Governance – BoardDocs (BoardDocs (North America - US)).