Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 08, 2025 - 02:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 30, 2025 - 14:16 UTC
Scheduled
Impact: Please be advised that we will be performing routine maintenance on our systems. Only sites scheduled for an update to the Diligent One Platform on this day will be impacted. For these sites, "BoardEffect" may become briefly unavailable during this time window. We apologize for any inconvenience this may cause.
What do you need to do?: Plan to perform items requiring "BoardEffect" in the impacted regions outside of the scheduled maintenance window timeline.
Contact: For any questions or if you experience a disruption other than above, please contact BoardEffect Support: support@boardeffect.com
Posted Oct 30, 2025 - 14:16 UTC
This scheduled maintenance affected: Boards & Governance – BoardEffect (BoardEffect (North America - US)).