Third-Party Manager - Some users may experience issues loading the Dashboard in the EU Region

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Nov 30, 2023 - 16:59 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 30, 2023 - 16:58 UTC

Investigating

Some users in the EU region may experience issues when clicking on the dashboard link, the dashboard may not load.
Posted Nov 30, 2023 - 16:58 UTC
This incident affected: Compliance - Third-Party Manager (Third-Party Manager (Europe - Germany)).