Boards - Service disruption in Canada and US
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Apr 20, 2024 - 02:48 UTC
Investigating
We are currently investigating this issue.
Posted Apr 20, 2024 - 02:37 UTC
This incident affected: Board & Leadership - Boards (Boards (North America - Canada), Boards (North America - US)).