Secure file sharing - Our service is currently experiencing service disruptions in the Canada and Australia regions
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Mar 25, 2024 - 08:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2024 - 07:39 UTC
Investigating
Our service is currently experiencing a disruption in the Canada and Australia regions, and some customers may not be able to access certain features or functionalities.
Posted Mar 25, 2024 - 07:16 UTC
This incident affected: Board & Leadership - Secure File Sharing (Secure File Sharing (North America - Canada), Secure File Sharing (Asia Pacific - Australia)).