Contact Center - Clients unable to reach Diligent Customer Support via phone
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 23:00 UTC
Monitoring
The issue is resolved and we are continuing to monitor the situation.
Posted Mar 19, 2024 - 22:33 UTC
Identified
This issue has been identified as an issue with a Third Party Service Provider preventing calls from reaching our call center. To contact support in the meantime, please contact: support@diligent.com
Posted Mar 19, 2024 - 21:29 UTC
Investigating
Clients are currently unable to reach our contact center via telephone. To contact support, please use our contact email: support@diligent.com.
Posted Mar 19, 2024 - 21:21 UTC
This incident affected: Diligent Contact Center (Diligent Contact Center (North America - US)).