Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2025 - 08:00 UTC
Scheduled
Services/Location: Third-Party Manager in North America - US Region
Impact: Please be advised that we will be performing routine maintenance on our systems. As a result, certain functionalities of Third-Party Manager mainly Due Diligence Questionnaires and Intake Forms, will not be available during this period. We apologize for any inconvenience this may cause.
What do you need to do?: Plan to perform tasks requiring Third-Party Manager execution in the impacted regions outside of the scheduled maintenance window.
Contact: For any questions or if you experience a disruption other than above, please contact Diligent Support: diligent.com/support
Posted Mar 12, 2025 - 08:34 UTC
This scheduled maintenance affected: Compliance - Third-Party Manager (Third-Party Manager (North America - US)).