Boards - Service Disruption in APAC Region

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 14:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2025 - 07:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2025 - 07:34 UTC

Investigating

Users in the APAC region are currently experiencing a service disruption. Our team is actively investigating the issue with high priority. We apologize for the inconvenience and appreciate your patience as we work to resolve it.
Posted Jun 18, 2025 - 06:41 UTC
This incident affected: Board & Leadership - Boards (Boards (Asia Pacific - Australia)).