Third-Party Manager - Some users may have trouble accessing Third-Party Manager in the US region

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Nov 29, 2023 - 20:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2023 - 20:37 UTC

Identified

Users in the US Region may have trouble accessing Third-Party Manager. We are currently working to restore service as soon as possible.
Posted Nov 29, 2023 - 20:33 UTC
This incident affected: Compliance - Third-Party Manager (Third-Party Manager (North America - US)).