Email Notification Degradation for Outlook Users

Incident Report for Diligent Customer Facing

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 08:12 UTC

Identified

There is an issue impacting Outlook users, where email notifications may be delayed or not delivered. Microsoft is actively working on the issue. Please reference Microsoft's Status Page here: https://status.cloud.microsoft/m365
Posted Jan 23, 2026 - 02:06 UTC