iCompass - Some Users May Experience Service Slowness

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Nov 09, 2023 - 19:06 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 09, 2023 - 19:05 UTC

Investigating

Some users may experience some slow performance when using the service.
Posted Nov 09, 2023 - 17:31 UTC
This incident affected: Mission Driven - iCompass (iCompass (North America - Canada), iCompass (North America - US)).