BoardDocs - Users Experiencing Latency Issues

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Sep 30, 2024 - 19:57 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2024 - 19:53 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 30, 2024 - 19:53 UTC

Investigating

Users are experiencing latency issues. Our team is prioritizing this and actively investigating.
Posted Sep 30, 2024 - 19:33 UTC
This incident affected: Mission Driven - BoardDocs (BoardDocs (North America - US)).