Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 17 days ago. Mar 15, 2025 - 14:33 UTC
Scheduled
Impact: Please be advised that we will be performing routine maintenance on our systems. As a result, certain functionalities of "Third-Party Manager," mainly Due Diligence Questionnaires and Intake Forms, will not be available during this period. We apologize for any inconvenience this may cause.
What do you need to do?: Plan to perform tasks requiring "Third-Party Manager" execution in the impacted regions outside of the scheduled maintenance window.
Contact: For any questions or if you experience a disruption other than above, please contact Diligent Support: diligent.com/support
Posted 17 days ago. Mar 15, 2025 - 14:32 UTC
This scheduled maintenance affected: Compliance - Third-Party Manager (Third-Party Manager (North America - US)).