Results - Service Degradation Impacting Users In Non-US Regions

Incident Report for Diligent Customer Facing

Resolved

This incident has been resolved.
Posted May 28, 2026 - 05:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 28, 2026 - 04:29 UTC

Identified

Users are currently experiencing service degradation in non-US regions. The Results app remains accessible via the highbond.com domain while we investigate the issue. Thank you for your understanding and patience!
Posted May 28, 2026 - 03:23 UTC
This incident affected: Platform - Results (Results (North America - Canada), Results (Europe - Germany), Results (Europe - UK), Results (Africa - South Africa), Results (Asia Pacific - Australia), Results (Asia Pacific - Japan), Results (Asia Pacific - Singapore), Results (South America - Brazil)).